hero image

Platform Support

Supported Platforms for the Vision Tool Family

The table below shows the operating systems and processor hardware platforms that are supported by Concept Engineering's Vision tool family (StarVision® PRO, RTLvision® PRO, SpiceVision® PRO, GateVision® PRO). For floating license environments, customers need to load and set up the flexnet.tgz package for licensing (can be downloaded from the same location as the visualization tool itself).

Operating System Processor Hardware Directory in Package
Windows 32 Bit Intel x86 (Pentium, etc.) ILP32 win32
Windows 64 Bit Intel x64 (AMD64, EM64T) LLP64 (or P64) win64
Solaris 10 Sun Sparc V9 LP64 sun10.64
Linux glibc 2.5+
tested on RHEL
x86_64 (AMD64, EM64T) LP64 linux64
Intel x86 (Pentium, etc.) ILP32 linux32

Supported Platforms for the Nlview Software Components

The table below shows the operating systems and processor hardware platforms that are supported by Concept Engineering's Nlview software components.

Operating System Processor Hardware Directory in Package
Windows 10, 8, 7, Vista, XP
(with Visual C 6.0 or later)
Intel x86 ILP32 win32
Windows 10, 8, 7, XP x64
(with Visual Studio 2005 or later)
x86_64 (AMD64, EM64T) P64 win64
Solaris 7-10 Sun Sparc ILP32 sun7
Sun Sparc V9 LP64 sun7.64
Solaris 10 Intel x86 ILP32 sun10.x86
x86_64 (AMD64, EM64T) LP64 sun10.x86_64
Linux glibc 2.3 Intel x86 ILP32 linux23
x86_64 (AMD64, EM64T) LP64 linux23.x86_64
Linux glibc 2.2 Intel x86 ILP32 linux22
x86_64 (AMD64, EM64T) LP64 linux22.x86_64
Linux glibc 2.17 64-bit IBM PowerPC Little Endian (Power8) LP64 linux217.ppc64le
HP-UX 11.00 PA-RISC 1.1 ILP32 hp11
PA-RISC 2.0W LP64 hp11.64
AIX ≥ 5.1 32-bit PowerPC (Power4) ILP32 aix5
64-bit PowerPC (Power4) LP64 aix5.64
FreeBSD ≥ 5.3 Intel x86 ILP32 freebsd5

Linux glibc 2.3 is good for all Linux distributions based on glibc version 2.3 or newer, including: RHEL3, RHEL4, RHEL5, RHEL6, and higher.

Linux glibc 2.2 is only needed for very old Linux distributions based on glibc version 2.2, including: Redhat6, Redhat7, Suse7, SLES8, etc.

Linux glibc 2.17 is good for Linux distributions based on glibc version 2.17 or newer, including: RHEL7.2, and higher.